THE FREEDOM COIN (TFC)
THE COIN YOU CAN BANK ON

MASTERNODE SETUP GUIDE

STEP 1 : Preparing Masternodes
Freedomcoin wallet running on your local computer with at least 5000 Freedomcoincoins for every masternode with a static IP
and open port 7118 for masternodes.
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.

- Choose the place where you will hold your masternodes dirs (you need 1Gb free space for every masternode)
- Create folder "FreedomcoinMN1" there
- Copy file "Freedomcoin-qt.exe" in folder "FreedomcoinMN1”
- Create in folder "FreedomcoinMN1" new folder "data”
- Copy file "blk0001.dat" and folder "txleveldb" in created folder "data”
- Rename "Freedomcoin-qt.exe" to the "Freedomcoin-mn1.exe”
- Press Win+R and type "cmd" and press Enter
- Now type there: echo start Freedomcoin-mn1.exe -datadir=./data > %homepath%/Desktop/startmn1.cmd
- Move file "startmn1.cmd" from Desktop to the "FreedomcoinMN1" folder
- Repeat the process from step 2 for each masternode you want to created, with changing mn1 to mn2, mn3
- Run startmn1.cmd, startmn2.cmd and startmn3.cmd, wait for complete loading wallets and complete syncing with blockchain
- Now you can exit from each running masternode wallets

STEP 2 : Preparing Controller Wallet
Freedomcoin wallet running on your local computer with at least 5000 Freedomcoincoins for every masternode with a static IP
and open port 7118 for masternodes.
1 - Open your main wallet where you have your coins
2 - Go to Receive tab
3 - Press button "New address" and enter "Masternode 1" in Label (do not check "Stealth address")
3.1 - Press button "New address" and enter "Masternode 2" in Label (do not check "Stealth address")
3.2 - Press button "New address" and enter "Masternode 3" in Label (do not check "Stealth address")
4 - Send to all this address exactly 5000 Freedomcoin by one transaction. This can be done by going to Send button and clicking on add
recipient two times. And fill all 3 address on pay to and 5000 as amount.
5 - Wait for 1 confirmation of transaction and go to the Debug console
6 - Run command "masternode genkey" and write down generated key (this is your masternode private key)
7 - Run command "masternode outputs" and write down hexnumbers (this is your masternode tx) and digit after ":" (this is tx index)
You will get 3 output like
{ "60835a7d867d335434925c32f38902268e131e99a5821557d3e77f8ca3829fd8" : "0",
"60835a7d867d335434925c32f38902268e131e99a5821557d3e77f8ca3829fd8" : "1",
"60835a7d867d335434925c32f38902268e131e99a5821557d3e77f8ca3829fd8" : "2" }
8 - Go to Masternodes tab and
8 - Go to Masternodes tab and switch to the "My Masternodes"
9 - Press button "Create"
10 - Enter "Alias" - "MN1" (do not use spaces and special charatcers)
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11 - Enter "Address" - "YOUREXTERNALIP:PORT" (your external white ip and port for masternode)
12 - Enter "Privkey" - masternode private key you generated with "masternode genkey"
13 - Enter "TxHash" - masternode tx from "masternode outputs" command
14 - Enter "Output Index" - tx index from "masternode outputs" command
15 - Now you can press "Ok"
16 - Repeat process from step 6 for MN2 and MN3. With renaming MN1 to MN2 and MN3 and changing port When you get to step 7
"masternode outputs" in second time you will see 2 lines with txhash and index. You must choose the First line with txhash for MN1
second for MN2 third for MN3.
17 - Press "Update" and you will see all three masternodes in list with status "Not in the masternode list. "Steps 8-15 creates
masternode.conf. You can skip this steps and create it by yourself. It have format:
ALIAS IP:PORT PRIVKEY TXHASH OUTPUTINDEX One line - one masternode config

STEP 3 : Configuring Masternodes

1 - Go to "FreedomcoinMN1/data" folder
2 - Open "Freedomcoin.conf" in Notepad
3 - Type there: port=PORT masternode=1 masternodeaddr=IP:PORT masternodeprivkey=PRIVKEY
4 - Replace PORT with port for your Masternode 1, IP:PORT with your external white ip and the same port for you Masternode 1
5 - Replace PRIVKEY with masternode private key you generated with "masternode genkey" in controller wallet for Masternode 1
6 - Save it and repeat process for Masternode 2 and Masternode 3.

STEP 4 : Starting Masternodes

1 - Now you can restart all your masternodes by executing the file "startmn1.cmd", "startmn2.cmd" and "startmn3.cmd"
2 - Go to controller wallet, check that your coins in Masternode 1, 2 and 3 addresses have at least 15 confirmations.
3 - Go to Masternodes tab and switch to the "My Masternodes"
4 –Press "Start All"
**********************************************************************************
Thats all folks. You have created 3 working masternodes. Don't be afraid to running PoS on controller wallet. It will not damage your
masternode transactions because all masternode coins will be locked and excluded from PoS.

Controller-Cold-Setup

This is the advised Method to setup your Masternodes. The wallet containing the coins does not have to be exposed and can run on your
local computer. It does not have to run all the time and you are not vulnerable to someone hacking your VPS because all he can do when
he hacked your VPS is stop your MNs but not steal your coins! Desktop Wallet Setup In the first steps the desktop wallet will be setup. This
is the wallet you can run on your local PC. When the masternodes are connected, this wallet can be closed and the PC does not have to run
in order for the masternodes to generate rewards.
We will create an address, private key and transaction for each masternode (MN in the following) and show the necessary steps for
configuration.
Open Console: Tools ? Debug window
1st Step
• Type “getaccountaddress MN1” and press Enter. This is the address your masternode will be affiliated to.
2nd Step
• You can view all created addresses under 'Receiving Addresses'
• Send exactly 5000 coins to the created MN address. Click on “add recipient” to add lines so you can send to all nodes in one
transaction.
• Now create (or open) the “masternode.conf” this file is located under %appdata%\Roaming\Freedomcoin.
• Make sure you have the right extension!
• We will now add a Line for each MN with the following Format:
• *Begin by entering and alias IP:port
• *Alias: The name of the MN receiving address (we named them MN1, MN2, …)
• *IP: The static IP of your server (If you don’t have one scroll down to find out where to get one!)
• *Port: A port the MN will connect to. The port is fixed to 7118 and you need a separate IP (VPS) for each running node!(edited)
• You cannot have more than one node per IP make sure the port is 7118. If you don’t have a linux VPS by now please scroll down to
“Get a Linux VPS first”
• Next we get the “masternodeprivkey“.
• *Open debug console again, type “masternode genkey” and press enter.
• *Copy the output keys to the config.
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•
•
•
•

The private keys are used for voting and identify you as the real owner so don’t share them
Next we will add txhash and outputindex. Go to the debug console again, type “masternode outputs” and press enter.
If you send the coins in one transaction the “txhash” will be the same. If you add a masternode later, another tuple will be added. So
every masternode has a unique pair of txhash and outputindex
Copy the information to the config file (Make sure you don’t forget the index!)

make sure you add these nodes before running your wallet please:
addnode=45.77.146.147
addnode=45.77.244.73
addnode=45.63.83.95
addnode=108.61.185.240
addnode=45.76.132.103
addnode=45.63.116.92
addnode=45.76.19.14
addnode=144.202.60.139
addnode=108.61.203.84
addnode=207.148.13.76
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•

Open and Run the Freedomcoin wallet for the first time. In the lower left hand corner of the User Interface, you will see “Synchronizing
with network” and other sync messages each time you open your Freedomcoin Wallet. If there is a problem synchronizing, it may say
“No Block Source Available” instead. If this happens, just close and re-open the wallet until it synchronizes

•
•
•
•

Go to Help -> Debug Console.
In the Console window enter getaccountaddress 0 and copy the result.
This is your MASTERNODE DEPOSIT ADDRESS, where you will deposit the coins to create a masternode.
Pay 5000 TFC exactly into this address. No more, no less.

•

Go to RUN -> %appdata% -> Common Files -> Freedomcoin Folder -> Open Wallet Configuration File. Open the file in Note and paste
the following two lines.Config file is located as Freedomcoin.cnf

masternode=1
masternodeprivkey=
rpcuser=user
rpcpassword=ytoi0s3xuTqrVrF
rpcallowip=127.0.0.1
daemon=1
server=1
listen=1
port=7118
rpcport=7117
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•
•
•
•
•
•
•

In the Console Debug window enter "masternode genkey" and copy the result. This is your MASTERNODE PRIVKEY. This is your
MASTERNODE PRIVKEY.
Go back to the config file in Notepad and paste your privkey after the equals sign of “masternodeprivkey=”. Now save and close the
file.
Close the wallet by going to File -> Exit. Go to firewall settings and add 7118 in the incoming port list. windows firewall -> Advance
settings -> Inbound Rules -> NewRule(Right side) -> Port -> 7118
Open the Freedomcoin Wallet again by running FreedomcoinCoin-Core.exe. This is how you will always start the wallet going forward.
Go to Help -> Debug Console. Enter "masternode start". You will see the response “Masternode started successfully”.
Congratulations, your masternode is now running.
Now click the Masternodes tab that is now visible. All masternodes need to be active for a certain amount of blocks before they are
recognized by the network and eligible for rewards.
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Create wallet.dat file for you masternode wallet
Create tfc collateral address on you wallet - send 5000 tfc exactly to this address wait for at least 10 confirmations then open the debug
consolue and type the following:
Masternode genkey
Masternode outputs
• Copy this detail you will use it later.
• OPEN Putty and Login to your VPS Terminal/Console:
• After you have successfully logged in you should execute the following commands one line at a time and press "Y" followed by the
"Enter" key where prompted :)
########################### ssh via putty ############################
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install nano htop git
sudo apt-get install software-properties-common
sudo apt-get install build-essential libtool autotools-dev pkg-config libssl-dev
sudo apt-get install libboost-all-dev
sudo apt-get install libevent-dev
sudo apt-get install libminiupnpc-dev
sudo apt-get install autoconf
sudo apt-get install automake
sudo add-apt-repository ppa:bitcoin/bitcoin
sudo apt-get update
sudo apt-get install libdb4.8-dev libdb4.8++-dev
sudo apt-get install libgmp-dev
########################### sidenote ############################
•
•
•
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• OPEN COLLATERAL WALLET
• create masternode fill in ip and port :7118 if you have not done so
• get info on created masternode
• copy and paste in vps nano and add the list of masternode to the config like you did with your wallet "addnode section"
save and exit
########################### ssh via putty continue ############################
cd (optional)
sudo git clone http://github.com/TheFreedomCoin/Freedom-Coin
cd Freedom-Coin/src
chmod +x leveldb/build_detect_platform
cd leveldb && make libleveldb.a libmemenv.a
cd ..
make -f makefile.unix # Headless
Reboot
**** Log into VPS and continue ***
cd
cd Freedom-Coin/src
./Freedomcoind (this should give a warning - and generate a rpcuser for your wallet on screen - copy this detail you will use it in a few
steps.)
############################ copy the rpc details to your freedomcoin.conf
rpcuser=Freedomcoinrpc
rpcpassword= hRjtgo5222346eiMfz2c3L b1pVD2c3LeuKRjtgo522MVHpm4a
#######################
nano ~/.Freedomcoin/Freedomcoin.conf
#######paste the rpc details to your freedomcoin.conf and then add the following and replace VPSIPADRESS &
YOURMASTERNODEPRIVATEKEY with your values ######
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masternodeprivkey=YOURMASTERNO DEPRIVATEKEY
masternodeaddr=VPSIPADDRESS:7118
masternode=1
daemon=1
server=1
listen=1
port=7118
rpcport=7117
rpcallowip=127.0.0.1
addnode=45.77.146.147
addnode=45.77.244.73
addnode=45.63.83.95
addnode=108.61.185.240
addnode=45.76.132.103
addnode=45.63.116.92
addnode=45.76.19.14
addnode=144.202.60.139
addnode=108.61.203.84
addnode=207.148.13.76
####################now save this doc
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./Freedomcoind -daemon
./Freedomcoind getinfo
########## you can run a watch to
watch ./Freedomcoind getinfo
########### Aftr the sync goto you collateral wallet and start the your masternode. Then type the following and you should see your
masternode collateral tx-txindex with an “ENABLED” next to it, J
./Freedomcoind masternode list
If not and your see “DISABLED” then something went wrong L.
####################### not for all and only if you want to here is basic Firewall setup with explorer and website enabled
requirements:
sudo apt-get install ufw
sudo ufw allow ssh
sudo ufw allow 22
sudo ufw allow 80
sudo ufw allow 443
sudo ufw allow 3001
sudo ufw allow 7117
sudo ufw allow 7118
sudo ufw enable
# and yes J

